Question

Hello Community!
Some time ago I developed a functionality  on a custom package oriented to the version
bpmonline sales enterprise & marketing & service enterprise 7.11.0 being that the development was related to service entities, Marketing and Sales.

Currently I need to upload that development to an environment in bpmonline sales team 7.13.1, and when i try to install my package gives me an error that does not find certain dependent packages for example MarketingSoftkeyEnu.

What is the process that should be followed to implement it and obviously get out the functionality associated with entities of the marketing and service module?

By chance I have installed and unlocked the package in another environment bpmonline sales enterprise & marketing & service enterprise 7.12, where I have another development package. I made a copy of that environment and tried:
1. Set the imported package as a defect and its corresponding prefix
2. Remove items from the package associated with marketing and service
3. Remove fields from lookups in schemas that are related to those entities
4. Eliminate package dependencies: MarketingSoftkeyEnu & ServiceEnterpriseSoftkey

At this point:
* When I try to make changes to an entity and save the changes I get the following error:
Error while saving: Collection item with unique identifier "{AE0E45CA-C495-4FE7-A39D-3AB7278E1617}" not found.

When trying to generate code, compile, etc. I ended up giving the following error:
Unexpected character encountered while parsing value: =. Path '', line 0, position 0.

* Export the package and try to install the package into bpmonline sales team getting same error as the previous one.

Thank you!
Have a nice weekend

Regards

Like

1 comments

Bpm'online allows transferring packages only between the same version. Additionally transferring is possible only between the same products or from less bundle to a greater one. 

In your case, you'll need to merge the package manually. Try to remove the dependencies from the SysPackageDependency table and then compile the assembly and debug the functionality. Find all errors and resolve them manually. 

 

Log in or register to comment
Question

Hi Community,

I am getting Oracle error ''ORA-01691: unable to extend lob segment DLD_CRM.SYS_LOB0000118070C00012$$ by 128 in tablespace USERS" when trying to install custom package from dev to prod instance using "Export to pacakges to archive" and "Installed Applications->Add Application->Install from file" (Please see image below).

Both dev and prod instance are using oracle database.

 

Like

3 comments

Dear Fulgen,

It seems that this issue is connected with Oracle database structure. I think this article may help you with this issue: http://www.dba-oracle.com/t_ora_01691.htm

Best regards,
Angela

Angela Reyes,

Thanks Angela, we have already fixed the oracle database structure and we can now install package successfully.

We still have issue with our oracle database, we are encountering Oracle error "(ORA-00942) table or view does not exist" on submit case landing page.

 

We have already done other landing pages before in bpm online instance which uses ms sql database, and the system is working fine. So we are sure we did the same thing the only difference is that this time the bpm online instance is using oracle database. Hope you can help us, solve this issue.

Fulgen Ninofranco,

Have you checked server logs? They might have the information about missing table. 

Log in or register to comment
Question

Hi team

I need help in transferring my application package from Development to Test.

I am getting errors and the Application install from Zip file fails. The error relates to Data Binding.

This is my first application that I have configured and customised on bpm online studio. I see in configuration part, the system creates different data binding objects.

I created data bindings for my lookup contents and lookup objects.

What I need help with is to know: List of the objects I need to create data bindings for and what system carry's over as default.

For example:

The system properties, operation properties. Do I need to Data Bind the object and the property.

The Dashboards/Charts in custom sections etc

I have installed the Data Binding tool available on the bpm online market place

 

Like

8 comments

Hi Can anyone provide a little help please . thank you...

 

Hi!

In general, if an object you created or modified contains data in it data from this object must be binded to a package. For example if you created new lookup field data from this field must be transferred. This also includes new sections, details, system settings. This article can be useful for you: https://community.bpmonline.com/articles/detailed-description-system-tables-and-tips-their-data-binding. If you made any changes in section wizard, data from SysModuleEdit, SysSchemas and SysModuleEntity tables must be included as well. Usually error in the logs points what data is missing and it can be easily tracked and fixed. 

Best regards,
Angela

Thank you Angela. The article is very good and has provided me some answers regarding what should be included in data binding when deploying packages.

I am assuming I can remove all existing data bindings in Data tab and follow the article to add the data bindings again.

Are you able to provide clarification on the following:

I added some data bindings but there are quite a few I did not added (system added and I noticed it has some of the custom objects I created and then deleted from the package). If I delete all data bindings and then run compile all function would the required system data bindings will get added by system and I would only need to add the custom objects as per the document link you provided.

Thank you 

Waseem

 

Waseem Ishaq,

I would not recommend deleting anything from there unless you understand what data will be deleted and how it will affect the package. As I already mentioned, investigate installation logs - they must have data about missing values. 

Best regards,
Angela

Angela Reyes,

Thank you Angela. The log points to SysAdminUnitInWorkplace object with 6 Errors. Please see one of the Error text below.

2019-04-25 04:43:06,999 Error occurred while installing data "WiSysWorkplaceAdminUnits_41b796040a924d7188a062308589a57b" in package "Jobs". UId 5d313e72-174e-4068-a8d5-2308aa4365be: The UPDATE statement conflicted with the FOREIGN KEY constraint "FKmlE1TzlpVsXTth5hSlvtUUtQ". The conflict occurred in database "test-campbellcorporateservices", table "dbo.SysAdminUnit", column 'Id'.
The statement has been terminated.
UPDATE [dbo].[SysAdminUnitInWorkplace] WITH(ROWLOCK)
SET
    [ModifiedOn] = CONVERT(DATETIME, '2019-04-25 04:43:06.983', 121),
    [ModifiedById] = '{410006E1-CA4E-4502-A9EC-E54D922D2C00}',
    [SysWorkplaceId] = '{79770671-CDE2-4C0F-9078-A4FF68703DEF}',
    [SysAdminUnitId] = '{CBD52603-2DD9-49E7-8F5B-9B7A5175558B}'
WHERE
    [Id] = '{BB55A2E0-5747-4758-92EA-3FD87C561859}'

Waseem Ishaq,

From the error I can see that when the system tries to update 

SysAdminUnitInWorkplace it cannot do it because of some FK exception. To investigate why it happened search for all elements of the error message in the DB. It looks like that something from SysAdminUnit table is missing - it can be role or user.

Hi Angela

Thank you for your assistance I have successfully deployed the application to test.

My initial testing reveals I did not package Dashboards and Word Printables? Any suggestion..

How do I Bind Dashboards and Word Printables.

Thank tou Waseem Ishaq

Waseem Ishaq,

You can use 

https://marketplace.bpmonline.com/app/data-binding-tool application to bind data from daschoards and printables to you package. Just use "Bind data" button on the sections you want to bind. 

Log in or register to comment
Question

Hi Community,

We are transferring changes from dev instance to prod instance through 'Export packages to archive' in configuration from dev and 'Installed Applications' on Prod. But we noticed one thing Printables and Email Templates were not transferred. Any idea how we can fix this issue?

Like

1 comments

Hello Fulgen, 
 

Here is an example how to transfer the email template,
you shoukd just do it similarly:

1.For example I has first instance localhost:8001
I have created a template "Test" in lookup "Email templates" http://prntscr.com/n7t0if

2.Now the task is to correctly bind the template to the package EmailTemplatesTest
Binding can be added by pressing Add button http://prntscr.com/n7t2r5

3. Select object email message template and press OK http://prntscr.com/n7t5am
4. Setup the filter that will choose the correct records http://prntscr.com/n7t60h
For example, in my case, the record with specified Id will be bounded to the package http://prntscr.com/n7t6kd
(You can check what records meets the filter by pressing "Display data" button)
5. After template is binded, you should export package to the archive http://prntscr.com/n7t7sp

6. Install the package to another instance in installed applications section http://prntscr.com/n7tf5a 
7. Now the template is successfully transfered http://prntscr.com/n7thai 

FYI: If you will have problems with non english templates, try to bind to the package Email template localization object http://prntscr.com/n7t9es

Best regards,
Alex

Log in or register to comment